# CVE-2026-113655: ApostropheCMS: Same-parent page reorder in @apostrophecms/page move() re-ranks a restricted parent's children without create authorization


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-2jrp-qc93-h2j8

## What is CVE-2026-113655?

CVE-2026-113655 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, an authenticated editor with legitimate edit rights on a pre-existing ordinary page nested under a restricted parent can use the same-parent page move operation to change sibling ranks without create authorization on that parent. The non-default nesting must already exist, and the bypass is limited to sibling ordering rather than arbitrary content modification, confidentiality loss, or creation of the restricted nesting. This issue is fixed in version 4.33.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-113655?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.33.0 |
| `apostrophe` | npm | All versions | 4.33.0 |

## How do I fix CVE-2026-113655?

Upgrade apostrophe to 4.33.0 or later.

## Is CVE-2026-113655 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113655 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113655 and fix it if it is affected.

What it is: CVE-2026-113655 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113655 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.33.0
- apostrophe (npm): affected all versions; fixed in 4.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113655/ (Markdown: https://insights.sbomify.com/CVE-2026-113655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113655
- OSV: https://osv.dev/vulnerability/CVE-2026-113655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113655/
Summaries are generated and may contain mistakes; the official description above is the record.
