# CVE-2026-113656: ApostropheCMS: Unauthenticated unbounded multipart upload → disk-exhaustion DoS


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-89mh-mm8c-mv7f

## What is CVE-2026-113656?

CVE-2026-113656 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 1.5.5 of the ApostropheCMS Form add-on, its form submission route stages unbounded multipart uploads before form validation or authentication and lacks upload size, count, and rate limits. Repeated unauthenticated submissions can consume temporary disk storage and disrupt form handling or other host services. This issue is fixed in ApostropheCMS Form 1.5.5.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-113656?

2 open source packages ship an affected version, including @apostrophecms/form.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/form` | npm | All versions | 1.5.5 |
| `@apostrophecms/form` | npm | All versions | 1.5.5 |

## How do I fix CVE-2026-113656?

Upgrade @apostrophecms/form to 1.5.5 or later.

## Is CVE-2026-113656 being exploited?

There is no known exploitation of CVE-2026-113656 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113656 and fix it if it is affected.

What it is: CVE-2026-113656 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113656 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apostrophecms/form (npm): affected all versions; fixed in 1.5.5
- @apostrophecms/form (npm): affected all versions; fixed in 1.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113656/ (Markdown: https://insights.sbomify.com/CVE-2026-113656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113656
- OSV: https://osv.dev/vulnerability/CVE-2026-113656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113656/
Summaries are generated and may contain mistakes; the official description above is the record.
