# CVE-2026-113657: ApostropheCMS sanitize-html: SMIL animation namespace-prefix bypass allows javascript: URI injection (XSS)


- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** ECHO-bff4-095f-fba6, GHSA-374f-7chj-9948

## What is CVE-2026-113657?

CVE-2026-113657 is a low-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. From sanitize-html 2.17.7 until 2.18.0, an application configuration that permits namespace-prefixed SVG animation elements and the relevant URL-targeting attributes can bypass the SMIL URL protection because prefixed tag names do not match the unprefixed animation-element check. The bypass can rewrite a link destination to an unsafe URI after the sanitized SVG is rendered, with script execution occurring when a user activates the affected link; the default sanitizer configuration is not unconditionally affected. This issue is fixed in sanitize-html 2.18.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-113657?

2 open source packages ship an affected version, including sanitize-html.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | From 2.17.7 | 2.18.0 |
| `sanitize-html` | npm | From 2.17.7 | 2.18.0 |

## How do I fix CVE-2026-113657?

Upgrade sanitize-html to 2.18.0 or later.

## Is CVE-2026-113657 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113657 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113657 and fix it if it is affected.

What it is: CVE-2026-113657 is a low-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113657 exists.

Affected packages and fixed versions:
- sanitize-html (npm): affected from 2.17.7; fixed in 2.18.0
- sanitize-html (npm): affected from 2.17.7; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113657/ (Markdown: https://insights.sbomify.com/CVE-2026-113657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113657
- OSV: https://osv.dev/vulnerability/CVE-2026-113657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113657/
Summaries are generated and may contain mistakes; the official description above is the record.
