# CVE-2026-113658: ApostropheCMS: Unauthenticated CSV import requests leave rejected uploads in the system temporary directory


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-qhcq-9pm2-c9w9

## What is CVE-2026-113658?

CVE-2026-113658 is a high-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, the unauthenticated Rich Text CSV conversion route writes a multipart upload to the system temporary directory before checking its extension and does not remove the staged file when that validation rejects it. Repeated large rejected uploads, using the normal public CSRF cookie, can persistently consume temporary-disk capacity and may disrupt ApostropheCMS and other services that depend on the same partition. This issue is fixed in version 4.33.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-459 (Incomplete Cleanup), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-113658?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.33.0 |
| `apostrophe` | npm | All versions | 4.33.0 |

## How do I fix CVE-2026-113658?

Upgrade apostrophe to 4.33.0 or later.

## Is CVE-2026-113658 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113658 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113658 and fix it if it is affected.

What it is: CVE-2026-113658 is a high-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113658 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.33.0
- apostrophe (npm): affected all versions; fixed in 4.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113658/ (Markdown: https://insights.sbomify.com/CVE-2026-113658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113658
- OSV: https://osv.dev/vulnerability/CVE-2026-113658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113658/
Summaries are generated and may contain mistakes; the official description above is the record.
