# CVE-2026-113660: ApostropheCMS: Authenticated Object-Level Authorization Bypass in exist-in-locale Reveals Restricted Localized Draft Identifiers


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-vmxh-77cw-65j7

## What is CVE-2026-113660?

CVE-2026-113660 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, ApostropheCMS’s exist-in-locale API allows an authenticated low-privilege user to determine whether restricted documents exist in a specified locale and mode, including draft mode. The endpoint returns localized document identifiers without applying document-level view or edit authorization criteria. This issue is fixed in version 4.33.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-113660?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.33.0 |
| `apostrophe` | npm | All versions | 4.33.0 |

## How do I fix CVE-2026-113660?

Upgrade apostrophe to 4.33.0 or later.

## Is CVE-2026-113660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113660 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113660 and fix it if it is affected.

What it is: CVE-2026-113660 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113660 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.33.0
- apostrophe (npm): affected all versions; fixed in 4.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113660/ (Markdown: https://insights.sbomify.com/CVE-2026-113660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113660
- OSV: https://osv.dev/vulnerability/CVE-2026-113660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113660/
Summaries are generated and may contain mistakes; the official description above is the record.
