# CVE-2026-113661: ApostropheCMS: Incomplete CVE-2026-53606: `meta http-equiv=refresh` `content` still ships `javascript:` / `data:` URLs


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** ECHO-4932-55c5-4535, GHSA-cv27-6wvh-8x7j

## What is CVE-2026-113661?

CVE-2026-113661 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. Prior to sanitize-html 2.18.0, a non-default configuration that allows meta refresh elements and their http-equiv and content attributes can retain unsafe script or redirect destinations embedded in the refresh content value. This issue is fixed in sanitize-html 2.18.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-113661?

2 open source packages ship an affected version, including sanitize-html.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | All versions | 2.18.0 |
| `sanitize-html` | npm | All versions | 2.18.0 |

## How do I fix CVE-2026-113661?

Upgrade sanitize-html to 2.18.0 or later.

## Is CVE-2026-113661 being exploited?

There is no known exploitation of CVE-2026-113661 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113661 and fix it if it is affected.

What it is: CVE-2026-113661 is a medium-severity vulnerability in apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113661 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize-html (npm): affected all versions; fixed in 2.18.0
- sanitize-html (npm): affected all versions; fixed in 2.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113661/ (Markdown: https://insights.sbomify.com/CVE-2026-113661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113661
- OSV: https://osv.dev/vulnerability/CVE-2026-113661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113661/
Summaries are generated and may contain mistakes; the official description above is the record.
