# CVE-2026-113662: ApostropheCMS import-export: NoSQL injection via update-key value lets a crafted import match and overwrite an unidentified document


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-jqw5-w6h3-44g6

## What is CVE-2026-113662?

CVE-2026-113662 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.0 of the import-export module, an authenticated user with import access to a target type can supply an object or operator as an update-key value, causing the import query to match an unidentified existing document that the user has generic edit permission to modify. The normal findForEditing permission filter still limits the candidate documents, so the issue does not permit permission-free overwrite of arbitrary protected content. This issue is fixed in version 3.7.0.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-113662?

2 open source packages ship an affected version, including @apostrophecms/import-export.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.0 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.0 |

## How do I fix CVE-2026-113662?

Upgrade @apostrophecms/import-export to 3.7.0 or later.

## Is CVE-2026-113662 being exploited?

There is no known exploitation of CVE-2026-113662 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113662 and fix it if it is affected.

What it is: CVE-2026-113662 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113662 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.0
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113662/ (Markdown: https://insights.sbomify.com/CVE-2026-113662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113662
- OSV: https://osv.dev/vulnerability/CVE-2026-113662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113662/
Summaries are generated and may contain mistakes; the official description above is the record.
