# CVE-2026-113664: ApostropheCMS import-export tar guard misses './..' because it is a literal '../' substring test


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-97wv-p4xx-c7mg

## What is CVE-2026-113664?

CVE-2026-113664 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 3.7.0 of the import-export module, an authenticated importer can submit a tar entry whose normalized destination targets a directory while bypassing the literal parent-path substring guard. Opening that directory as a write stream emits an unhandled filesystem error that can terminate the Node.js process; the source establishes this static primitive but not an end-to-end exploit or controlled arbitrary file read or write. This issue is fixed in version 3.7.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-113664?

2 open source packages ship an affected version, including @apostrophecms/import-export.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.0 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.0 |

## How do I fix CVE-2026-113664?

Upgrade @apostrophecms/import-export to 3.7.0 or later.

## Is CVE-2026-113664 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113664 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113664 and fix it if it is affected.

What it is: CVE-2026-113664 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113664 exists.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.0
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113664/ (Markdown: https://insights.sbomify.com/CVE-2026-113664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113664
- OSV: https://osv.dev/vulnerability/CVE-2026-113664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113664/
Summaries are generated and may contain mistakes; the official description above is the record.
