# CVE-2026-113666: ApostropheCMS: Authenticated projection-exclusion prototype-member deletion in @apostrophecms/db-connect causes process-wide denial of service


- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-j5rq-xfvr-p969

## What is CVE-2026-113666?

CVE-2026-113666 is a high-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 1.1.0 of db-connect and 4.33.0 of ApostropheCMS, an account with view-draft access can submit a projection exclusion path that traverses through a constructor prototype chain to a shared prototype member when a consumer uses a SQLite, PostgreSQL, or multipostgres adapter and has a matching document. Every editing role has view-draft access, while guestApiAccess broadens this prerequisite to any logged-in account. The unsetNestedField helper then deletes the shared runtime member, causing persistent process-wide integrity and availability effects; the default MongoDB adapter is not affected. This issue is fixed in db-connect 1.1.0 and ApostropheCMS 4.33.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-113666?

4 open source packages ship an affected version, including @apostrophecms/db-connect and apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/db-connect` | npm | All versions | 1.1.0 |
| `@apostrophecms/db-connect` | npm | All versions | 1.1.0 |
| `apostrophe` | npm | All versions | 4.33.0 |
| `apostrophe` | npm | All versions | 4.33.0 |

## How do I fix CVE-2026-113666?

Upgrade @apostrophecms/db-connect to 1.1.0 or later.

## Is CVE-2026-113666 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113666 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113666 and fix it if it is affected.

What it is: CVE-2026-113666 is a high-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113666 exists.

Affected packages and fixed versions:
- @apostrophecms/db-connect (npm): affected all versions; fixed in 1.1.0
- @apostrophecms/db-connect (npm): affected all versions; fixed in 1.1.0
- apostrophe (npm): affected all versions; fixed in 4.33.0
- apostrophe (npm): affected all versions; fixed in 4.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113666/ (Markdown: https://insights.sbomify.com/CVE-2026-113666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113666
- OSV: https://osv.dev/vulnerability/CVE-2026-113666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113666/
Summaries are generated and may contain mistakes; the official description above is the record.
