CVE-2026-113669 ApostropheCMS: Cross-domain session token in URL confers session takeover

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-113669?

CVE-2026-113669 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026.

Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0 of ApostropheCMS and 1.6.1 of passport-bridge, cross-host or cross-locale session migration places a single-use bearer session token in a redirect URL. A client that obtains and redeems a still-valid, unconsumed token before its first use can adopt the associated session, including through the passport-bridge cross-locale flow. This issue is fixed in ApostropheCMS 4.33.0 and passport-bridge 1.6.1.

Weakness: CWE-598

Which versions are affected by CVE-2026-113669?

4 open source packages ship an affected version, including @apostrophecms/passport-bridge and apostrophe.

PackageAffectedFixed in
@apostrophecms/passport-bridge npmAll versions1.6.1
@apostrophecms/passport-bridge npmAll versions1.6.1
apostrophe npmAll versions4.33.0
apostrophe npmAll versions4.33.0

How do I fix CVE-2026-113669?

Upgrade @apostrophecms/passport-bridge to 1.6.1 or later.

Is CVE-2026-113669 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113669 exists.

Sources

Also known as GHSA-hhvr-8m24-qqr3.

Is CVE-2026-113669 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free