{"answers":{"affected":"4 open source packages ship an affected version, including @apostrophecms/passport-bridge and apostrophe.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113669 exists.","fix":"Upgrade @apostrophecms/passport-bridge to 1.6.1 or later.","what":"CVE-2026-113669 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-113669 and fix it if it is affected.\n\nWhat it is: CVE-2026-113669 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113669 exists.\n\nAffected packages and fixed versions:\n- @apostrophecms/passport-bridge (npm): affected all versions; fixed in 1.6.1\n- @apostrophecms/passport-bridge (npm): affected all versions; fixed in 1.6.1\n- apostrophe (npm): affected all versions; fixed in 4.33.0\n- apostrophe (npm): affected all versions; fixed in 4.33.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-113669/ (Markdown: https://insights.sbomify.com/CVE-2026-113669/index.md)","id":"CVE-2026-113669","markdown":"https://insights.sbomify.com/CVE-2026-113669/index.md","name":"CVE-2026-113669","record":{"aliases":["GHSA-hhvr-8m24-qqr3"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-598","name":"Use of HTTP Request With Sensitive Query String"}],"description":"ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0 of ApostropheCMS and 1.6.1 of passport-bridge, cross-host or cross-locale session migration places a single-use bearer session token in a redirect URL. A client that obtains and redeems a still-valid, unconsumed token before its first use can adopt the associated session, including through the passport-bridge cross-locale flow. This issue is fixed in ApostropheCMS 4.33.0 and passport-bridge 1.6.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ApostropheCMS: Cross-domain session token in URL confers session takeover","id":"CVE-2026-113669","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"This CVE is a duplicate of another CVE.","id":"CVE-2026-113670"},"packages":[{"ecosystem":"npm","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"@apostrophecms/passport-bridge","purl":null,"source":"GHSA-hhvr-8m24-qqr3"},{"ecosystem":"npm","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"@apostrophecms/passport-bridge","purl":"pkg:npm/%40apostrophecms/passport-bridge","source":"GHSA-hhvr-8m24-qqr3"},{"ecosystem":"npm","fixed":["4.33.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-hhvr-8m24-qqr3"},{"ecosystem":"npm","fixed":["4.33.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-hhvr-8m24-qqr3"}],"prev":{"headline":"ApostropheCMS: :_id/locales REST route omits the public-API authorization gate its sibling read routes enforce (unauthenticated doc-existence + locale metadata disclosure)","id":"CVE-2026-113668"},"products":["apostrophe","passport-bridge"],"published":"2026-10-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-23","vendors":["@apostrophecms","apostrophecms"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-113669/"}