# CVE-2026-113669: ApostropheCMS: Cross-domain session token in URL confers session takeover


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-hhvr-8m24-qqr3

## What is CVE-2026-113669?

CVE-2026-113669 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0 of ApostropheCMS and 1.6.1 of passport-bridge, cross-host or cross-locale session migration places a single-use bearer session token in a redirect URL. A client that obtains and redeems a still-valid, unconsumed token before its first use can adopt the associated session, including through the passport-bridge cross-locale flow. This issue is fixed in ApostropheCMS 4.33.0 and passport-bridge 1.6.1.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2026-113669?

4 open source packages ship an affected version, including @apostrophecms/passport-bridge and apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/passport-bridge` | npm | All versions | 1.6.1 |
| `@apostrophecms/passport-bridge` | npm | All versions | 1.6.1 |
| `apostrophe` | npm | All versions | 4.33.0 |
| `apostrophe` | npm | All versions | 4.33.0 |

## How do I fix CVE-2026-113669?

Upgrade @apostrophecms/passport-bridge to 1.6.1 or later.

## Is CVE-2026-113669 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113669 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113669 and fix it if it is affected.

What it is: CVE-2026-113669 is a medium-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113669 exists.

Affected packages and fixed versions:
- @apostrophecms/passport-bridge (npm): affected all versions; fixed in 1.6.1
- @apostrophecms/passport-bridge (npm): affected all versions; fixed in 1.6.1
- apostrophe (npm): affected all versions; fixed in 4.33.0
- apostrophe (npm): affected all versions; fixed in 4.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113669/ (Markdown: https://insights.sbomify.com/CVE-2026-113669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113669
- OSV: https://osv.dev/vulnerability/CVE-2026-113669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113669/
Summaries are generated and may contain mistakes; the official description above is the record.
