CVE-2026-113711 ApostropheCMS: Unauthenticated resource exhaustion via pre-auth aposBigUpload processing in @apostrophecms/import-export

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-113711?

CVE-2026-113711 is a high-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026.

Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0 of ApostropheCMS and 3.7.0 of the import-export module, import routes invoke bigUploadMiddleware without an early authorize callback, allowing unauthenticated requests to perform upload initialization, chunk storage, temporary processing, and attacker-declared cleanup work before the later user check rejects the import. This issue is fixed in ApostropheCMS 4.33.0 and import-export 3.7.0.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2026-113711?

4 open source packages ship an affected version, including @apostrophecms/import-export and apostrophe.

PackageAffectedFixed in
@apostrophecms/import-export npmAll versions3.7.0
@apostrophecms/import-export npmAll versions3.7.0
apostrophe npmAll versions4.33.0
apostrophe npmAll versions4.33.0

How do I fix CVE-2026-113711?

Upgrade @apostrophecms/import-export to 3.7.0 or later.

Is CVE-2026-113711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113711 exists.

Sources

Also known as GHSA-86wm-68pq-5jwq.

Is CVE-2026-113711 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free