# CVE-2026-113711: ApostropheCMS: Unauthenticated resource exhaustion via pre-auth aposBigUpload processing in @apostrophecms/import-export


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-86wm-68pq-5jwq

## What is CVE-2026-113711?

CVE-2026-113711 is a high-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 

### Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0 of ApostropheCMS and 3.7.0 of the import-export module, import routes invoke bigUploadMiddleware without an early authorize callback, allowing unauthenticated requests to perform upload initialization, chunk storage, temporary processing, and attacker-declared cleanup work before the later user check rejects the import. This issue is fixed in ApostropheCMS 4.33.0 and import-export 3.7.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-113711?

4 open source packages ship an affected version, including @apostrophecms/import-export and apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apostrophecms/import-export` | npm | All versions | 3.7.0 |
| `@apostrophecms/import-export` | npm | All versions | 3.7.0 |
| `apostrophe` | npm | All versions | 4.33.0 |
| `apostrophe` | npm | All versions | 4.33.0 |

## How do I fix CVE-2026-113711?

Upgrade @apostrophecms/import-export to 3.7.0 or later.

## Is CVE-2026-113711 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113711 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113711 and fix it if it is affected.

What it is: CVE-2026-113711 is a high-severity vulnerability in @apostrophecms apostrophe, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113711 exists.

Affected packages and fixed versions:
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.0
- @apostrophecms/import-export (npm): affected all versions; fixed in 3.7.0
- apostrophe (npm): affected all versions; fixed in 4.33.0
- apostrophe (npm): affected all versions; fixed in 4.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113711/ (Markdown: https://insights.sbomify.com/CVE-2026-113711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113711
- OSV: https://osv.dev/vulnerability/CVE-2026-113711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113711/
Summaries are generated and may contain mistakes; the official description above is the record.
