# CVE-2026-113713: virtualenv: Temporary app-data can leave dangling seed package links


- **Severity:** Medium 4.4 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** AZL-110103, BIT-virtualenv-2026-113713, DEBIAN-CVE-2026-113713, GHSA-4f8h-vr72-p32c, UBUNTU-CVE-2026-113713

## What is CVE-2026-113713?

CVE-2026-113713 is a medium-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. From 21.14.8 until 21.14.10, the app-data seeder can leave an environment linked to temporary package files that virtualenv deletes when creation finishes. The environment-variable and configuration-file forms of symlink_app_data can enable this state even though the command-line flag is disabled for temporary app-data. The resulting environment depends on a cache pathname that its owner no longer controls. This issue is fixed in version 21.14.10.

Weakness: CWE-377 (DEPRECATED: Insecure Temporary File)

## Which versions are affected by CVE-2026-113713?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | From 21.14.8 | 21.14.10 |
| `virtualenv` | PyPI | From 21.14.8 | 21.14.10 |
| `virtualenv` | PyPI | From 21.14.8 | 21.14.10 |

## How do I fix CVE-2026-113713?

Upgrade virtualenv to 21.14.10 or later.

## Is CVE-2026-113713 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113713 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113713 and fix it if it is affected.

What it is: CVE-2026-113713 is a medium-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113713 exists.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected from 21.14.8; fixed in 21.14.10
- virtualenv (PyPI): affected from 21.14.8; fixed in 21.14.10
- virtualenv (PyPI): affected from 21.14.8; fixed in 21.14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113713/ (Markdown: https://insights.sbomify.com/CVE-2026-113713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113713
- OSV: https://osv.dev/vulnerability/CVE-2026-113713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113713/
Summaries are generated and may contain mistakes; the official description above is the record.
