# CVE-2026-113714: virtualenv: Downloaded wheel selection and caching precede verification


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** BIT-virtualenv-2026-113714, DEBIAN-CVE-2026-113714, ECHO-ba42-b2d8-bef3, GHSA-494p-63j8-28p3, MINI-98qw-6qj6-47h8, UBUNTU-CVE-2026-113714

## What is CVE-2026-113714?

CVE-2026-113714 is a low-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, download_wheel() writes package-index downloads directly into the reusable wheel/house cache before selecting a verification target from pip's textual Saved output. With default-index digest comparison enabled, a controlled package index can inject a misleading Saved line through a discarded link's data-requires-python attribute; this forged-line variant also requires knowledge of an absolute path to the genuine bundled wheel. The wrong path can then be hashed, while a digest mismatch leaves the rejected archive in the cache for later selection without verification. A separate rejected-cache-file variant requires control over downloaded data or archive selection but not the forged-line prerequisites. Explicit custom-index exceptions are outside the promised PyPI comparison, and the issue does not independently bypass TLS or establish control of default PyPI. This issue is fixed in version 21.14.9.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2026-113714?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |

## How do I fix CVE-2026-113714?

Upgrade virtualenv to 21.14.9 or later.

## Is CVE-2026-113714 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113714 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113714 and fix it if it is affected.

What it is: CVE-2026-113714 is a low-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113714 exists.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113714/ (Markdown: https://insights.sbomify.com/CVE-2026-113714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113714
- OSV: https://osv.dev/vulnerability/CVE-2026-113714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113714/
Summaries are generated and may contain mistakes; the official description above is the record.
