# CVE-2026-113715: virtualenv: Venv configuration readback can reinterpret path boundaries


- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** AZL-110109, BIT-virtualenv-2026-113715, DEBIAN-CVE-2026-113715, ECHO-1c1f-97ee-320d, GHSA-qmx5-4p3x-wvqf, MINI-vhf9-phfj-ffp3, UBUNTU-CVE-2026-113715

## What is CVE-2026-113715?

CVE-2026-113715 is a low-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, the stdlib venv creator reads generated pyvenv.cfg with str.splitlines() and merges parsed keys over virtualenv's selected configuration. An untrusted caller who influences the destination pathname can include a line-boundary character such as U+2028 to inject keys including home and include-system-site-packages, causing path data to change configuration structure before final output. Setting include-system-site-packages to true weakens environment isolation, while an altered home can change which standard-library files the interpreter loads if the attacker also controls that location. The builtin creator does not use this readback path. This issue is fixed in version 21.14.9.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-113715?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |

## How do I fix CVE-2026-113715?

Upgrade virtualenv to 21.14.9 or later.

## Is CVE-2026-113715 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113715 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113715 and fix it if it is affected.

What it is: CVE-2026-113715 is a low-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113715 exists.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113715/ (Markdown: https://insights.sbomify.com/CVE-2026-113715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113715
- OSV: https://osv.dev/vulnerability/CVE-2026-113715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113715/
Summaries are generated and may contain mistakes; the official description above is the record.
