# CVE-2026-113716: virtualenv: Builtin creation follows linked environment directories


- **Severity:** Medium 4.5 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** AZL-110094, BIT-virtualenv-2026-113716, DEBIAN-CVE-2026-113716, ECHO-b16b-aede-f997, GHSA-cw65-gx24-rc82, MINI-7fpf-frpg-8g6v, UBUNTU-CVE-2026-113716

## What is CVE-2026-113716?

CVE-2026-113716 is a medium-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, the builtin creator calls ensure_dir() for executable, library, and package directories, and ensure_dir() accepts an existing symlink to a directory because exists() follows it. Interpreter creation, seed installation, and activation generation then write through the linked parent outside the requested destination when another local account prepared the tree and the invoking user can access the target. The --clear option removes the planted tree first, while ordinary creation reaches it; arbitrary attacker-selected output bytes are not established. This issue is fixed in version 21.14.9.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-113716?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |

## How do I fix CVE-2026-113716?

Upgrade virtualenv to 21.14.9 or later.

## Is CVE-2026-113716 being exploited?

There is no known exploitation of CVE-2026-113716 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113716 and fix it if it is affected.

What it is: CVE-2026-113716 is a medium-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113716 in the wild and no public exploit code.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113716/ (Markdown: https://insights.sbomify.com/CVE-2026-113716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113716
- OSV: https://osv.dev/vulnerability/CVE-2026-113716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113716/
Summaries are generated and may contain mistakes; the official description above is the record.
