# CVE-2026-113717: virtualenv: Pip seeding with download omits wheel digest verification


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** BIT-virtualenv-2026-113717, DEBIAN-CVE-2026-113717, ECHO-39b2-6d9f-c795, GHSA-cx28-75q4-x26q, MINI-q853-5qm6-353q, UBUNTU-CVE-2026-113717

## What is CVE-2026-113717?

CVE-2026-113717 is a low-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, PipInvoke.get_pip_install_cmd() handles --seeder pip --download by calling get_wheel(download=False) and then allowing pip to consult the configured index, bypassing virtualenv's download_wheel() and verify_wheel_digest() path. When virtualenv's default-index PyPI digest comparison remains enabled, an index candidate matching the bundled package and version can therefore be selected without comparison to PyPI SHA-256 metadata. Explicit custom-index settings already opt out of that comparison and remain outside this verification-bypass claim; the demonstrated configuration used a non-PyPI index while leaving the index environment variables unset so the comparison policy remained active. This condition does not independently defeat TLS or establish control of the index response. This issue is fixed in version 21.14.9.

Weakness: CWE-494 (Download of Code Without Integrity Check)

## Which versions are affected by CVE-2026-113717?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |

## How do I fix CVE-2026-113717?

Upgrade virtualenv to 21.14.9 or later.

## Is CVE-2026-113717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113717 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113717 and fix it if it is affected.

What it is: CVE-2026-113717 is a low-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113717 exists.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113717/ (Markdown: https://insights.sbomify.com/CVE-2026-113717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113717
- OSV: https://osv.dev/vulnerability/CVE-2026-113717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113717/
Summaries are generated and may contain mistakes; the official description above is the record.
