# CVE-2026-113722: virtualenv: Generated POSIX console launchers interpret destination paths as shell syntax


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** AZL-110112, BIT-virtualenv-2026-113722, DEBIAN-CVE-2026-113722, ECHO-4f9c-bd0b-6464, GHSA-c978-59m8-c77v, MINI-7hr2-3jjr-c5rc, ROOT-APP-PYPI-CVE-2026-113722, UBUNTU-CVE-2026-113722

## What is CVE-2026-113722?

CVE-2026-113722 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, virtualenv's ScriptMakerCustom and pip pass an incompletely quoted interpreter path to distlib ScriptMaker when generating POSIX console scripts. When the path contains a space or produces a shebang longer than 127 bytes, distlib emits a /bin/sh wrapper whose double-quoted interpreter path still expands command substitutions and backticks. An attacker who influences the environment destination can therefore execute commands with the user's privileges when the user later runs a generated launcher; environment creation and activation do not trigger the command. Existing launchers are not repaired by upgrading virtualenv alone and must be regenerated, while a later independent pip installation or upgrade can reintroduce an affected launcher because pip's vendored distlib is unchanged. The virtualenv fix is released in version 21.14.9.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-113722?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |

## How do I fix CVE-2026-113722?

Upgrade virtualenv to 21.14.9 or later.

## Is CVE-2026-113722 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113722 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113722 and fix it if it is affected.

What it is: CVE-2026-113722 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113722 exists.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113722/ (Markdown: https://insights.sbomify.com/CVE-2026-113722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113722
- OSV: https://osv.dev/vulnerability/CVE-2026-113722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113722/
Summaries are generated and may contain mistakes; the official description above is the record.
