# CVE-2026-113723: virtualenv: Bash prompt values can change meaning under older compatibility modes


- **Severity:** High 7.1 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** AZL-110079, AZL-110097, BIT-virtualenv-2026-113723, DEBIAN-CVE-2026-113723, ECHO-2c36-be90-38e4, GHSA-6w3r-xr62-4xcp, MINI-6j9q-xq2g-px5p, ROOT-APP-PYPI-CVE-2026-113723, UBUNTU-CVE-2026-113723

## What is CVE-2026-113723?

CVE-2026-113723 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.9, caller-supplied prompt text can become executable syntax in the bash activation prompt. An attacker must influence the value passed to virtualenv, and a user must subsequently activate the environment and draw the prompt. This vulnerability is fixed in 21.14.9.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-113723?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |
| `virtualenv` | PyPI | All versions | 21.14.9 |

## How do I fix CVE-2026-113723?

Upgrade virtualenv to 21.14.9 or later.

## Is CVE-2026-113723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113723 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113723 and fix it if it is affected.

What it is: CVE-2026-113723 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113723 exists.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9
- virtualenv (PyPI): affected all versions; fixed in 21.14.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113723/ (Markdown: https://insights.sbomify.com/CVE-2026-113723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113723
- OSV: https://osv.dev/vulnerability/CVE-2026-113723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113723/
Summaries are generated and may contain mistakes; the official description above is the record.
