# CVE-2026-113726: virtualenv activate runs commands from the environment name in zsh with PROMPT_SUBST


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** AZL-110076, AZL-110100, BIT-virtualenv-2026-113726, DEBIAN-CVE-2026-113726, ECHO-bef4-55b6-f81b, GHSA-5vjq-rrrf-7h2q, MINI-c7hj-g37h-88m6, ROOT-APP-PYPI-CVE-2026-113726, UBUNTU-CVE-2026-113726

## What is CVE-2026-113726?

CVE-2026-113726 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.13.0, the bash activate script that zsh also sources leaves the environment name unescaped; from 21.13.0 until 21.14.4, it escapes backslashes, dollar signs, and backticks only when BASH_VERSION is set, so zsh receives the raw value. The script assigns that value to PS1. In zsh with PROMPT_SUBST, an attacker-influenced environment directory, --prompt, or VIRTUALENV_PROMPT value containing command, parameter, or arithmetic expansion syntax can therefore execute commands in the user's shell each time the prompt is drawn. A percent sign is separately interpreted as a zsh prompt escape but does not by itself execute commands. Plain zsh with PROMPT_SUBST disabled and bash are not affected by this mechanism. This issue is fixed in version 21.14.4.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-113726?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.4 |
| `virtualenv` | PyPI | All versions | 21.14.4 |
| `virtualenv` | PyPI | All versions | 21.14.4 |

## How do I fix CVE-2026-113726?

Upgrade virtualenv to 21.14.4 or later.

## Is CVE-2026-113726 being exploited?

There is no known exploitation of CVE-2026-113726 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113726 and fix it if it is affected.

What it is: CVE-2026-113726 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113726 in the wild and no public exploit code.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.4
- virtualenv (PyPI): affected all versions; fixed in 21.14.4
- virtualenv (PyPI): affected all versions; fixed in 21.14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113726/ (Markdown: https://insights.sbomify.com/CVE-2026-113726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113726
- OSV: https://osv.dev/vulnerability/CVE-2026-113726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113726/
Summaries are generated and may contain mistakes; the official description above is the record.
