# CVE-2026-113730: OGNL stricter-invocation block list bypass via java.lang.reflect reflection proxies


- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** CLEANSTART-2026-NN19344, DEBIAN-CVE-2026-113730, GHSA-crwc-vw2r-qr6m, UBUNTU-CVE-2026-113730

## What is CVE-2026-113730?

CVE-2026-113730 is a medium-severity vulnerability in orphan-oss ognl, published on 20 Oct 2026. 

### Official description

OGNL is an Object Graph Navigation Library for Java. Prior to 3.4.13, the optional stricter-invocation mode in OgnlRuntime.invokeMethod checks the declaring class of the method that OGNL invokes but does not block java.lang.reflect.Method, java.lang.reflect.Constructor, or java.lang.reflect.Field. An attacker-controlled expression can invoke one of these reflection objects as a proxy for a method on a blocked class, causing the real operation to execute inside JDK reflection without passing through the stricter-invocation check again. Exploitation requires an application to evaluate untrusted OGNL expressions, use the default or an equivalently permissive MemberAccess that permits reflection, and rely on stricter invocation as a sandbox. Applications using a restrictive MemberAccess, including Apache Struts with SecurityMemberAccess, are not affected by this bypass. This issue is fixed in 3.4.13.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-113730?

2 open source packages ship an affected version, including ognl:ognl.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ognl:ognl` | Maven | All versions | 3.4.13 |
| `ognl:ognl` | Maven | All versions | 3.4.13 |

## How do I fix CVE-2026-113730?

Upgrade ognl:ognl to 3.4.13 or later.

## Is CVE-2026-113730 being exploited?

There is no known exploitation of CVE-2026-113730 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113730 and fix it if it is affected.

What it is: CVE-2026-113730 is a medium-severity vulnerability in orphan-oss ognl, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113730 in the wild and no public exploit code.

Affected packages and fixed versions:
- ognl:ognl (Maven): affected all versions; fixed in 3.4.13
- ognl:ognl (Maven): affected all versions; fixed in 3.4.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113730/ (Markdown: https://insights.sbomify.com/CVE-2026-113730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113730
- OSV: https://osv.dev/vulnerability/CVE-2026-113730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113730/
Summaries are generated and may contain mistakes; the official description above is the record.
