# CVE-2026-113732: virtualenv activate.fish runs commands from a path or prompt with a backslash before a quote


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** AZL-110091, BIT-virtualenv-2026-113732, DEBIAN-CVE-2026-113732, ECHO-8675-a321-3c8f, GHSA-c947-3pg5-gm8q, MINI-47pm-25vr-57pc, ROOT-APP-PYPI-CVE-2026-113732, UBUNTU-CVE-2026-113732

## What is CVE-2026-113732?

CVE-2026-113732 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. Prior to 21.14.2, FishActivator inherits ViaTemplateActivator.quote(), which uses POSIX shlex.quote() even though fish interprets backslashes and single quotes differently. An attacker-influenced environment path, --prompt, or VIRTUALENV_PROMPT value containing a backslash before a quote can therefore terminate the generated fish literal and execute command substitution when the user sources activate.fish. This issue is fixed in version 21.14.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-113732?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | All versions | 21.14.2 |
| `virtualenv` | PyPI | All versions | 21.14.2 |
| `virtualenv` | PyPI | All versions | 21.14.2 |

## How do I fix CVE-2026-113732?

Upgrade virtualenv to 21.14.2 or later.

## Is CVE-2026-113732 being exploited?

There is no known exploitation of CVE-2026-113732 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113732 and fix it if it is affected.

What it is: CVE-2026-113732 is a high-severity vulnerability in pypa virtualenv, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113732 in the wild and no public exploit code.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected all versions; fixed in 21.14.2
- virtualenv (PyPI): affected all versions; fixed in 21.14.2
- virtualenv (PyPI): affected all versions; fixed in 21.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113732/ (Markdown: https://insights.sbomify.com/CVE-2026-113732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113732
- OSV: https://osv.dev/vulnerability/CVE-2026-113732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113732/
Summaries are generated and may contain mistakes; the official description above is the record.
