# CVE-2026-113743: Tenstorrent tt-metal load_checkpoints.py load_hf_state_dict_filtered path traversal


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-xwr8-qcf8-4867

## What is CVE-2026-113743?

CVE-2026-113743 is a medium-severity vulnerability in Tenstorrent tt-metal, published on 21 Oct 2026. 

### Official description

A weakness has been identified in Tenstorrent tt-metal up to 0.80.0. The affected element is the function load_hf_state_dict_filtered of the file models/tt_transformers/tt/load_checkpoints.py. This manipulation of the argument weight_map causes path traversal. The attack may be initiated remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 0.81.0-dev20261016 is sufficient to fix this issue. Patch name: 4851ccf347f6903c3d819eed60705600386e52c3. It is suggested to upgrade the affected component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-113743?


## How do I fix CVE-2026-113743?

No fix has been published for CVE-2026-113743 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-113743 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113743 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113743 and fix it if it is affected.

What it is: CVE-2026-113743 is a medium-severity vulnerability in Tenstorrent tt-metal, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-113743 exists.

Affected product: Tenstorrent tt-metal. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113743/ (Markdown: https://insights.sbomify.com/CVE-2026-113743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113743
- OSV: https://osv.dev/vulnerability/CVE-2026-113743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113743/
Summaries are generated and may contain mistakes; the official description above is the record.
