# CVE-2026-113786: pypdf: Unvalidated JPEG image data loading


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-113786, ECHO-a02d-80f2-f8bd, GHSA-5hx5-vpf9-5wcv, UBUNTU-CVE-2026-113786

## What is CVE-2026-113786?

CVE-2026-113786 is a low-severity vulnerability in py-pdf pypdf, published on 21 Oct 2026. 

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to 6.21.1, an attacker can craft a PDF containing image data labeled with the /DCTDecode filter that causes Pillow to select and invoke an unintended image parser when the image is loaded. Environments without the optional Pillow dependency are not affected. This issue is fixed in version 6.21.1.

Weakness: CWE-20 (Improper Input Validation), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-113786?

2 open source packages ship an affected version, including pypdf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.21.1 |
| `pypdf` | PyPI | All versions | 6.21.1 |

## How do I fix CVE-2026-113786?

Upgrade pypdf to 6.21.1 or later.

## Is CVE-2026-113786 being exploited?

There is no known exploitation of CVE-2026-113786 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113786 and fix it if it is affected.

What it is: CVE-2026-113786 is a low-severity vulnerability in py-pdf pypdf, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113786 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.21.1
- pypdf (PyPI): affected all versions; fixed in 6.21.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113786/ (Markdown: https://insights.sbomify.com/CVE-2026-113786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113786
- OSV: https://osv.dev/vulnerability/CVE-2026-113786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113786/
Summaries are generated and may contain mistakes; the official description above is the record.
