# CVE-2026-113788: Lagoon core ssh service vulnerable to remote code execution


- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-f8mw-q232-qjfp

## What is CVE-2026-113788?

CVE-2026-113788 is a critical vulnerability in uselagoon lagoon, published on 21 Oct 2026. 

### Official description

Lagoon is an application delivery platform for Kubernetes. Versions prior to 2.33.1 have a vulnerability in the `ssh` service in Lagoon core that would allow an attacker to execute arbitrary code which could lead to, among other things, elevated administrative permissions. It is mitigated by the fact that an attacker must have a Lagoon user account. Exploitation may be detected by checking the container logs of the `ssh` service for: `too many arguments`. The vulnerability was fixed in Lagoon v2.33.2, which is included in the `lagoon/lagoon-core` helm chart v1.62.2. As a workaround, the `ssh` service in Lagoon core can be disabled. The `ssh-portal` service and components are not effected and can continue to be used.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-113788?


## How do I fix CVE-2026-113788?

No fix has been published for CVE-2026-113788 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-113788 being exploited?

There is no known exploitation of CVE-2026-113788 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-113788 and fix it if it is affected.

What it is: CVE-2026-113788 is a critical vulnerability in uselagoon lagoon, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-113788 in the wild and no public exploit code.

Affected product: uselagoon lagoon. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-113788/ (Markdown: https://insights.sbomify.com/CVE-2026-113788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-113788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-113788
- OSV: https://osv.dev/vulnerability/CVE-2026-113788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-113788/
Summaries are generated and may contain mistakes; the official description above is the record.
