{"answers":{"affected":"2 open source packages ship an affected version, including software.amazon.jdbc:aws-advanced-jdbc-wrapper.","exploited":"There is no known exploitation of CVE-2026-11400 in the wild and no public exploit code.","fix":"Upgrade software.amazon.jdbc:aws-advanced-jdbc-wrapper to 4.0.1 or later.","what":"CVE-2026-11400 is a high-severity vulnerability in AWS Advanced JDBC Wrapper, published on 5 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-11400 and fix it if it is affected.\n\nWhat it is: CVE-2026-11400 is a high-severity vulnerability in AWS Advanced JDBC Wrapper, published on 5 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-11400 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven): affected from 3.0.0; fixed in 4.0.1\n- software.amazon.jdbc:aws-advanced-jdbc-wrapper (Maven): affected from 3.0.0; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-11400/ (Markdown: https://insights.sbomify.com/CVE-2026-11400/index.md)","id":"CVE-2026-11400","markdown":"https://insights.sbomify.com/CVE-2026-11400/index.md","name":"CVE-2026-11400","record":{"aliases":["GHSA-mhww-p97m-3368"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS JDBC Wrapper","requires_auth":"low_privilege","summary":"A low-privilege user can escalate privileges to rds_superuser via a crafted function in the AWS Advanced JDBC Wrapper for Aurora PostgreSQL.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-426","name":"Untrusted Search Path"}],"description":"An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper.\n\nTo remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege Escalation in AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL","id":"CVE-2026-11400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege Escalation in AWS Advanced Go Wrapper for Amazon Aurora PostgreSQL","id":"CVE-2026-11401"},"packages":[{"ecosystem":"Maven","fixed":["4.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"software.amazon.jdbc:aws-advanced-jdbc-wrapper","purl":null,"source":"GHSA-mhww-p97m-3368"},{"ecosystem":"Maven","fixed":["4.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"software.amazon.jdbc:aws-advanced-jdbc-wrapper","purl":"pkg:maven/software.amazon.jdbc/aws-advanced-jdbc-wrapper","source":"GHSA-mhww-p97m-3368"}],"prev":{"headline":"Missing authorization in Helpdesk Support Ticket System for WooCommerce","id":"CVE-2026-11399"},"products":["AWS Advanced JDBC Wrapper"],"published":"2026-06-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-20","vendors":["AWS"]},"summary":"A low-privilege user can escalate privileges to rds_superuser via a crafted function in the AWS Advanced JDBC Wrapper for Aurora PostgreSQL.","url":"https://insights.sbomify.com/CVE-2026-11400/"}