# CVE-2026-11401: Privilege Escalation in AWS Advanced Go Wrapper for Amazon Aurora PostgreSQL

> A low-privilege user can escalate to rds_superuser via a crafted function in the AWS Advanced Go Wrapper for Aurora PostgreSQL.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-r236-5pc3-3qcp, GO-2026-5601

## What is CVE-2026-11401?

CVE-2026-11401 is a high-severity vulnerability in AWS Advanced Go Wrapper, published on 5 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced Go Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through the affected wrapper.

To remediate this issue, users should upgrade to the AWS Advanced Go Wrapper release 2026-05-26

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-11401?

34 open source packages ship an affected version, including github.com/aws/aws-advanced-go-wrapper/auth-helpers, github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager and github.com/aws/aws-advanced-go-wrapper/awssql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/aws/aws-advanced-go-wrapper/auth-helpers` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/auth-helpers` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/auth-helpers` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager` | Go | All versions | 1.1.2 |
| `github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager` | Go | All versions | 1.1.2 |
| `github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager` | Go | All versions | 1.1.2 |
| `github.com/aws/aws-advanced-go-wrapper/awssql` | Go | All versions | None |
| `github.com/aws/aws-advanced-go-wrapper/awssql/v2` | Go | All versions | 2.0.1 |
| `github.com/aws/aws-advanced-go-wrapper/awssql/v2` | Go | All versions | 2.0.1 |
| `github.com/aws/aws-advanced-go-wrapper/awssql/v2` | Go | All versions | 2.0.1 |
| `github.com/aws/aws-advanced-go-wrapper/custom-endpoint` | Go | All versions | 1.0.4 |
| `github.com/aws/aws-advanced-go-wrapper/custom-endpoint` | Go | All versions | 1.0.4 |
| `github.com/aws/aws-advanced-go-wrapper/custom-endpoint` | Go | All versions | 1.0.4 |
| `github.com/aws/aws-advanced-go-wrapper/federated-auth` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/federated-auth` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/federated-auth` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/iam` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/iam` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/iam` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/mysql-driver` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/mysql-driver` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/mysql-driver` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/okta` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/okta` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/okta` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/otlp` | Go | All versions | 1.0.7 |
| `github.com/aws/aws-advanced-go-wrapper/otlp` | Go | All versions | 1.0.7 |
| `github.com/aws/aws-advanced-go-wrapper/otlp` | Go | All versions | 1.0.7 |
| `github.com/aws/aws-advanced-go-wrapper/pgx-driver` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/pgx-driver` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/pgx-driver` | Go | All versions | 1.1.1 |
| `github.com/aws/aws-advanced-go-wrapper/xray` | Go | All versions | None |
| `github.com/aws/aws-advanced-go-wrapper/xray` | Go | All versions | 1.07 |
| `github.com/aws/aws-advanced-go-wrapper/xray` | Go | All versions | 1.07 |

## How do I fix CVE-2026-11401?

Upgrade github.com/aws/aws-advanced-go-wrapper/auth-helpers to 1.1.1 or later.

## Is CVE-2026-11401 being exploited?

There is no known exploitation of CVE-2026-11401 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11401 and fix it if it is affected.

What it is: CVE-2026-11401 is a high-severity vulnerability in AWS Advanced Go Wrapper, published on 5 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-11401 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go): affected all versions; fixed in 1.1.1
- github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go): affected all versions; fixed in 1.1.1
- github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go): affected all versions; fixed in 1.1.1
- github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go): affected all versions; fixed in 1.1.2
- github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go): affected all versions; fixed in 1.1.2
- github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go): affected all versions; fixed in 1.1.2
- github.com/aws/aws-advanced-go-wrapper/awssql (Go): affected all versions; no fix listed
- github.com/aws/aws-advanced-go-wrapper/awssql/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/aws/aws-advanced-go-wrapper/awssql/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/aws/aws-advanced-go-wrapper/awssql/v2 (Go): affected all versions; fixed in 2.0.1
- github.com/aws/aws-advanced-go-wrapper/custom-endpoint (Go): affected all versions; fixed in 1.0.4
- github.com/aws/aws-advanced-go-wrapper/custom-endpoint (Go): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11401/ (Markdown: https://insights.sbomify.com/CVE-2026-11401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11401
- OSV: https://osv.dev/vulnerability/CVE-2026-11401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11401/
Summaries are generated and may contain mistakes; the official description above is the record.
