{"answers":{"affected":"2 open source packages ship an affected version, including vllm.","exploited":"There is no known exploitation of CVE-2026-114050 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.31.0 or later.","what":"CVE-2026-114050 is a high-severity vulnerability in vllm-project vllm, published on 21 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-114050 and fix it if it is affected.\n\nWhat it is: CVE-2026-114050 is a high-severity vulnerability in vllm-project vllm, published on 21 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-114050 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected all versions; fixed in 0.31.0\n- vllm (PyPI): affected all versions; fixed in 0.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-114050/ (Markdown: https://insights.sbomify.com/CVE-2026-114050/index.md)","id":"CVE-2026-114050","markdown":"https://insights.sbomify.com/CVE-2026-114050/index.md","name":"CVE-2026-114050","record":{"aliases":["GHSA-p92p-rxj5-7p2x"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"vLLM before 0.31.0 uses a client-supplied multimodal uuid verbatim as cache identity with no consistency check on cache hits, allowing engine crashes. Unauthenticated attackers can desynchronize the P0/P1 processor caches to trigger a fatal token-placeholder mismatch, killing the entire serving instance until restarted.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM before 0.31.0 Remote Engine Crash via Forged Multimodal UUID","id":"CVE-2026-114050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vLLM before 0.31.0 Denial of Service via min_tokens in /inference/v1/generate","id":"CVE-2026-114051"},"packages":[{"ecosystem":"PyPI","fixed":["0.31.0"],"introduced":["0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-p92p-rxj5-7p2x"},{"ecosystem":"PyPI","fixed":["0.31.0"],"introduced":["0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-p92p-rxj5-7p2x"}],"prev":{"headline":"vLLM before 0.31.0 Stale allowed_token_ids Mask via InputBatch.condense","id":"CVE-2026-114049"},"products":["vllm"],"published":"2026-10-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-21","vendors":["vllm-project"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-114050/"}