# CVE-2026-114050: vLLM before 0.31.0 Remote Engine Crash via Forged Multimodal UUID


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-p92p-rxj5-7p2x

## What is CVE-2026-114050?

CVE-2026-114050 is a high-severity vulnerability in vllm-project vllm, published on 21 Oct 2026. 

### Official description

vLLM before 0.31.0 uses a client-supplied multimodal uuid verbatim as cache identity with no consistency check on cache hits, allowing engine crashes. Unauthenticated attackers can desynchronize the P0/P1 processor caches to trigger a fatal token-placeholder mismatch, killing the entire serving instance until restarted.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-114050?

2 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.31.0 |
| `vllm` | PyPI | All versions | 0.31.0 |

## How do I fix CVE-2026-114050?

Upgrade vllm to 0.31.0 or later.

## Is CVE-2026-114050 being exploited?

There is no known exploitation of CVE-2026-114050 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114050 and fix it if it is affected.

What it is: CVE-2026-114050 is a high-severity vulnerability in vllm-project vllm, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114050 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.31.0
- vllm (PyPI): affected all versions; fixed in 0.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114050/ (Markdown: https://insights.sbomify.com/CVE-2026-114050/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114050
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114050
- OSV: https://osv.dev/vulnerability/CVE-2026-114050

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114050/
Summaries are generated and may contain mistakes; the official description above is the record.
