# CVE-2026-114053: vLLM 0.7.3 before 0.31.0 RCE via mm_processor_kwargs.code_revision


- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-h3rc-6mm3-gc2m

## What is CVE-2026-114053?

CVE-2026-114053 is a critical vulnerability in vllm-project vllm, published on 21 Oct 2026. 

### Official description

vLLM from 0.7.3 before 0.31.0 forwards the request-supplied mm_processor_kwargs.code_revision to Transformers AutoProcessor.from_pretrained, letting clients select which revision of a model's dynamic processor code is imported when trust_remote_code is enabled. An attacker controlling a revision in the served model repository can send a multimodal request to the unauthenticated /tokenize endpoint to execute arbitrary Python in the vLLM API process.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-114053?

2 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.7.3 | 0.31.0 |
| `vllm` | PyPI | From 0.7.3 | 0.31.0 |

## How do I fix CVE-2026-114053?

Upgrade vllm to 0.31.0 or later.

## Is CVE-2026-114053 being exploited?

There is no known exploitation of CVE-2026-114053 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114053 and fix it if it is affected.

What it is: CVE-2026-114053 is a critical vulnerability in vllm-project vllm, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114053 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.7.3; fixed in 0.31.0
- vllm (PyPI): affected from 0.7.3; fixed in 0.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114053/ (Markdown: https://insights.sbomify.com/CVE-2026-114053/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114053
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114053
- OSV: https://osv.dev/vulnerability/CVE-2026-114053

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114053/
Summaries are generated and may contain mistakes; the official description above is the record.
