# CVE-2026-114055: vLLM 0.7.3 before 0.31.0 DoS via Unvalidated mm_processor_kwargs


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-gx7p-2j49-hfq4

## What is CVE-2026-114055?

CVE-2026-114055 is a high-severity vulnerability in vllm-project vllm, published on 21 Oct 2026. 

### Official description

vLLM from 0.7.3 before 0.31.0 contains an uncontrolled resource consumption vulnerability that allows remote clients to control multimodal processor parameters by supplying per-request mm_processor_kwargs. Attackers can set large image size, patch count, crop count, or frame count values in Isaac, InternVL, H2OVL, and other processors to exhaust memory and terminate the shared server.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-114055?

2 open source packages ship an affected version, including vllm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.7.3 | 0.31.0 |
| `vllm` | PyPI | From 0.7.3 | 0.31.0 |

## How do I fix CVE-2026-114055?

Upgrade vllm to 0.31.0 or later.

## Is CVE-2026-114055 being exploited?

There is no known exploitation of CVE-2026-114055 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114055 and fix it if it is affected.

What it is: CVE-2026-114055 is a high-severity vulnerability in vllm-project vllm, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114055 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.7.3; fixed in 0.31.0
- vllm (PyPI): affected from 0.7.3; fixed in 0.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114055/ (Markdown: https://insights.sbomify.com/CVE-2026-114055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114055
- OSV: https://osv.dev/vulnerability/CVE-2026-114055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114055/
Summaries are generated and may contain mistakes; the official description above is the record.
