# CVE-2026-114060: SvelteKit before 3.0.0 Open Redirect via Enhanced Form Actions


- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-pfhg-q3qv-9q6r

## What is CVE-2026-114060?

CVE-2026-114060 is a low-severity vulnerability in sveltejs kit, published on 21 Oct 2026. 

### Official description

SvelteKit (@sveltejs/kit) before 3.0.0 contains an open redirect vulnerability in enhanced form actions (use:enhance) on routes accepting paths beginning with a double slash. Attackers can craft action paths starting with // that become protocol-relative URLs, causing non-redirect form results to navigate victims to attacker-controlled sites.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-114060?

2 open source packages ship an affected version, including @sveltejs/kit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | All versions | 3.0.0 |
| `@sveltejs/kit` | npm | All versions | 3.0.0 |

## How do I fix CVE-2026-114060?

Upgrade @sveltejs/kit to 3.0.0 or later.

## Is CVE-2026-114060 being exploited?

There is no known exploitation of CVE-2026-114060 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114060 and fix it if it is affected.

What it is: CVE-2026-114060 is a low-severity vulnerability in sveltejs kit, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114060 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected all versions; fixed in 3.0.0
- @sveltejs/kit (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114060/ (Markdown: https://insights.sbomify.com/CVE-2026-114060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114060
- OSV: https://osv.dev/vulnerability/CVE-2026-114060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114060/
Summaries are generated and may contain mistakes; the official description above is the record.
