# CVE-2026-114061: SvelteKit before 3.0.0 XSS via Cache-Control Header in Prerendered Pages


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-27mw-82g8-phjj

## What is CVE-2026-114061?

CVE-2026-114061 is a low-severity vulnerability in sveltejs kit, published on 21 Oct 2026. 

### Official description

SvelteKit (@sveltejs/kit) before 3.0.0 contains a cross-site scripting vulnerability in prerendered pages because a cache-control header value set via setHeaders is inserted without escaping into a <meta http-equiv="cache-control"> tag. An attacker who can influence that untrusted value at prerender time can break out of the content attribute and inject HTML or JavaScript that executes when users visit the page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-114061?

2 open source packages ship an affected version, including @sveltejs/kit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | All versions | 3.0.0 |
| `@sveltejs/kit` | npm | All versions | 3.0.0 |

## How do I fix CVE-2026-114061?

Upgrade @sveltejs/kit to 3.0.0 or later.

## Is CVE-2026-114061 being exploited?

There is no known exploitation of CVE-2026-114061 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114061 and fix it if it is affected.

What it is: CVE-2026-114061 is a low-severity vulnerability in sveltejs kit, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114061 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected all versions; fixed in 3.0.0
- @sveltejs/kit (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114061/ (Markdown: https://insights.sbomify.com/CVE-2026-114061/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114061
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114061
- OSV: https://osv.dev/vulnerability/CVE-2026-114061

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114061/
Summaries are generated and may contain mistakes; the official description above is the record.
