# CVE-2026-114076: Trigger.dev before 4.5.2 Blind SSRF via Alert Channel Webhook URL


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-3mx6-67xp-8wvp, GHSA-q567-cr4x-96w4, MINI-jhh5-jghj-5qjj

## What is CVE-2026-114076?

CVE-2026-114076 is a medium-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 

### Official description

Trigger.dev before 4.5.2 contains a blind server-side request forgery vulnerability that allows authenticated tenants to make the webapp server send POST requests to internal hosts by setting an unvalidated webhook alert channel URL. Attackers can point the webhook at internal services or cloud metadata addresses and trigger alerts to scan internal hosts, send state-changing POSTs, or reach IMDSv1 via redirects.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-114076?

2 open source packages ship an affected version, including trigger.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trigger.dev` | npm | All versions | 4.5.2 |
| `trigger.dev` | npm | All versions | 4.5.2 |

## How do I fix CVE-2026-114076?

Upgrade trigger.dev to 4.5.2 or later.

## Is CVE-2026-114076 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114076 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114076 and fix it if it is affected.

What it is: CVE-2026-114076 is a medium-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114076 exists.

Affected packages and fixed versions:
- trigger.dev (npm): affected all versions; fixed in 4.5.2
- trigger.dev (npm): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114076/ (Markdown: https://insights.sbomify.com/CVE-2026-114076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114076
- OSV: https://osv.dev/vulnerability/CVE-2026-114076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114076/
Summaries are generated and may contain mistakes; the official description above is the record.
