# CVE-2026-114079: Trigger.dev before 4.5.6 Cross-Environment Deployment Cancel via Cancel Endpoint


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-4672-hwv6-gq62, GHSA-49rg-27pr-85f9, MINI-26h7-w46f-66qg

## What is CVE-2026-114079?

CVE-2026-114079 is a medium-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 

### Official description

Trigger.dev before 4.5.6 contains an improper authorization vulnerability that allows holders of lower-trust environment API keys to cancel other environments' deployments because DeploymentService.getDeployment scopes lookups by projectId only. Attackers with a dev, preview, or CI secret key can POST to the deployment cancel endpoint to cancel in-progress production deployments within the same project.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-114079?

2 open source packages ship an affected version, including trigger.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trigger.dev` | npm | All versions | 4.5.6 |
| `trigger.dev` | npm | All versions | 4.5.6 |

## How do I fix CVE-2026-114079?

Upgrade trigger.dev to 4.5.6 or later.

## Is CVE-2026-114079 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114079 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114079 and fix it if it is affected.

What it is: CVE-2026-114079 is a medium-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114079 exists.

Affected packages and fixed versions:
- trigger.dev (npm): affected all versions; fixed in 4.5.6
- trigger.dev (npm): affected all versions; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114079/ (Markdown: https://insights.sbomify.com/CVE-2026-114079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114079
- OSV: https://osv.dev/vulnerability/CVE-2026-114079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114079/
Summaries are generated and may contain mistakes; the official description above is the record.
