# CVE-2026-114086: Trigger.dev before 4.5.5 Unauthenticated Realtime Stream Data Injection via Streams Endpoint


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-59h8-w5q6-mfmp, GHSA-h43q-m2j9-rjvp, MINI-rr9q-856q-4fmj

## What is CVE-2026-114086?

CVE-2026-114086 is a medium-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 

### Official description

Trigger.dev before 4.5.5 contains a missing authentication vulnerability in the realtime streams POST handler that allows unauthenticated attackers to inject data into run streams. Attackers can send POST requests to /realtime/v1/streams/:runId/:streamId with a predictable run friendlyId to inject arbitrary data into any environment's realtime stream, including production.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-114086?

2 open source packages ship an affected version, including trigger.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trigger.dev` | npm | All versions | 4.5.5 |
| `trigger.dev` | npm | All versions | 4.5.5 |

## How do I fix CVE-2026-114086?

Upgrade trigger.dev to 4.5.5 or later.

## Is CVE-2026-114086 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114086 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114086 and fix it if it is affected.

What it is: CVE-2026-114086 is a medium-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114086 exists.

Affected packages and fixed versions:
- trigger.dev (npm): affected all versions; fixed in 4.5.5
- trigger.dev (npm): affected all versions; fixed in 4.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114086/ (Markdown: https://insights.sbomify.com/CVE-2026-114086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114086
- OSV: https://osv.dev/vulnerability/CVE-2026-114086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114086/
Summaries are generated and may contain mistakes; the official description above is the record.
