# CVE-2026-114087: Trigger.dev before 4.5.6 Authentication Bypass via Hardcoded Default Secrets


- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** GHSA-jm68-q9wf-qf39, GHSA-pqxw-g93w-hj9x, MINI-cj67-cf79-3qmc

## What is CVE-2026-114087?

CVE-2026-114087 is a critical vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 

### Official description

Trigger.dev before 4.5.6 self-hosted Docker Compose deployments using the default secrets from hosting/docker/.env.example allow authentication bypass because the hardcoded MAGIC_LINK_SECRET lets anyone forge valid magic link tokens. Unauthenticated attackers can log in as any email address, then reach Postgres, Redis, and ClickHouse with default credentials from runner containers on infrastructure networks, compromising all tenant data.

Weakness: CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2026-114087?

2 open source packages ship an affected version, including trigger.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trigger.dev` | npm | All versions | 4.5.6 |
| `trigger.dev` | npm | All versions | 4.5.6 |

## How do I fix CVE-2026-114087?

Upgrade trigger.dev to 4.5.6 or later.

## Is CVE-2026-114087 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114087 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114087 and fix it if it is affected.

What it is: CVE-2026-114087 is a critical vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114087 exists.

Affected packages and fixed versions:
- trigger.dev (npm): affected all versions; fixed in 4.5.6
- trigger.dev (npm): affected all versions; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114087/ (Markdown: https://insights.sbomify.com/CVE-2026-114087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114087
- OSV: https://osv.dev/vulnerability/CVE-2026-114087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114087/
Summaries are generated and may contain mistakes; the official description above is the record.
