# CVE-2026-114088: Trigger.dev before 4.5.4 Hardcoded Coordinator Secret Authentication Bypass via Socket.IO


- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-gg6r-gp4c-89hp, GHSA-j3cj-67wq-q96g, MINI-pgpx-hh5m-2cwr

## What is CVE-2026-114088?

CVE-2026-114088 is a high-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 

### Official description

Trigger.dev before 4.5.4 contains a hardcoded default secret vulnerability in the /coordinator Socket.IO namespace that allows unauthenticated attackers to connect using the published coordinator-secret value. Attackers can emit READY_FOR_EXECUTION to retrieve decrypted run environment variables or send TASK_RUN_FAILED_TO_RUN and similar events to tamper with arbitrary runs.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-114088?

2 open source packages ship an affected version, including trigger.dev.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trigger.dev` | npm | All versions | 4.5.4 |
| `trigger.dev` | npm | All versions | 4.5.4 |

## How do I fix CVE-2026-114088?

Upgrade trigger.dev to 4.5.4 or later.

## Is CVE-2026-114088 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114088 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114088 and fix it if it is affected.

What it is: CVE-2026-114088 is a high-severity vulnerability in triggerdotdev trigger.dev, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114088 exists.

Affected packages and fixed versions:
- trigger.dev (npm): affected all versions; fixed in 4.5.4
- trigger.dev (npm): affected all versions; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114088/ (Markdown: https://insights.sbomify.com/CVE-2026-114088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114088
- OSV: https://osv.dev/vulnerability/CVE-2026-114088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114088/
Summaries are generated and may contain mistakes; the official description above is the record.
