# CVE-2026-114094: Dulwich before 1.2.9 Arbitrary File Write via DOS drive letter paths


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** AZL-109890, CLSA-2026-1791442146, CLSA-2026-1793014066, ECHO-6327-848d-ed17, GHSA-8mcx-5rqc-vhmf, GHSA-pxf3-54vf-v638, MINI-7c25-chwj-r9qv, MINI-mmp4-48vx-hrjf, UBUNTU-CVE-2026-114094

## What is CVE-2026-114094?

CVE-2026-114094 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 

### Official description

Dulwich before 1.2.9 fails to validate DOS drive letter prefixes in Git tree path elements on Windows, allowing arbitrary file write. Attackers can craft a malicious repository with a tree entry named 'C:' that bypasses NTFS validation and writes files outside the worktree to achieve remote code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-114094?

2 open source packages ship an affected version, including dulwich.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | All versions | 1.2.9 |
| `dulwich` | PyPI | All versions | 1.2.9 |

## How do I fix CVE-2026-114094?

Upgrade dulwich to 1.2.9 or later.

## Is CVE-2026-114094 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114094 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114094 and fix it if it is affected.

What it is: CVE-2026-114094 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114094 exists.

Affected packages and fixed versions:
- dulwich (PyPI): affected all versions; fixed in 1.2.9
- dulwich (PyPI): affected all versions; fixed in 1.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114094/ (Markdown: https://insights.sbomify.com/CVE-2026-114094/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114094
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114094
- OSV: https://osv.dev/vulnerability/CVE-2026-114094

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114094/
Summaries are generated and may contain mistakes; the official description above is the record.
