# CVE-2026-114095: Dulwich before 1.2.9 Infinite Loop DoS via Pack.resolve_object


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** AZL-109893, DEBIAN-CVE-2026-114095, ECHO-c5e3-e788-b542, GHSA-35mr-4567-66vg, GHSA-r78r-wr5r-rqfm, MINI-596m-vr3f-9q26, MINI-fm7p-f8jw-crjr, UBUNTU-CVE-2026-114095

## What is CVE-2026-114095?

CVE-2026-114095 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 

### Official description

Dulwich before 1.2.9 contains a denial of service vulnerability in Pack.resolve_object that allows attackers to cause infinite recursion via self-referential OFS_DELTA objects. Attackers can supply a malicious packfile with an OFS_DELTA delta_offset of 0 to exhaust CPU during clone, fetch, or cat-file operations.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-114095?

2 open source packages ship an affected version, including dulwich.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | All versions | 1.2.9 |
| `dulwich` | PyPI | All versions | 1.2.9 |

## How do I fix CVE-2026-114095?

Upgrade dulwich to 1.2.9 or later.

## Is CVE-2026-114095 being exploited?

There is no known exploitation of CVE-2026-114095 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114095 and fix it if it is affected.

What it is: CVE-2026-114095 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114095 in the wild and no public exploit code.

Affected packages and fixed versions:
- dulwich (PyPI): affected all versions; fixed in 1.2.9
- dulwich (PyPI): affected all versions; fixed in 1.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114095/ (Markdown: https://insights.sbomify.com/CVE-2026-114095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114095
- OSV: https://osv.dev/vulnerability/CVE-2026-114095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114095/
Summaries are generated and may contain mistakes; the official description above is the record.
