# CVE-2026-114096: Dulwich 0.24.0 before 1.2.8 Symlink Write-Through via porcelain.checkout paths


- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114096, ECHO-0ab0-979a-5ca7, GHSA-8w8g-wq8h-fq33, GHSA-8wh8-hpg9-jvx8, MINI-w3jg-42j6-7wpf, MINI-xjfw-pg99-j7hf, UBUNTU-CVE-2026-114096

## What is CVE-2026-114096?

CVE-2026-114096 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 

### Official description

Dulwich from 0.24.0 before 1.2.8 contains a symlink following vulnerability in porcelain.checkout(paths=[...]) that allows attackers to write arbitrary files by abusing raw os.open without O_NOFOLLOW. Attackers can craft a repository where a worktree symlink points to .git/hooks/post-checkout, so restoring the file from a tag writes a malicious hook for code execution.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-114096?

2 open source packages ship an affected version, including dulwich.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | From 0.24.0 | 1.2.8 |
| `dulwich` | PyPI | From 0.24.0 | 1.2.8 |

## How do I fix CVE-2026-114096?

Upgrade dulwich to 1.2.8 or later.

## Is CVE-2026-114096 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114096 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114096 and fix it if it is affected.

What it is: CVE-2026-114096 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114096 exists.

Affected packages and fixed versions:
- dulwich (PyPI): affected from 0.24.0; fixed in 1.2.8
- dulwich (PyPI): affected from 0.24.0; fixed in 1.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114096/ (Markdown: https://insights.sbomify.com/CVE-2026-114096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114096
- OSV: https://osv.dev/vulnerability/CVE-2026-114096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114096/
Summaries are generated and may contain mistakes; the official description above is the record.
