# CVE-2026-114097: Dulwich 0.23.1 before 1.2.8 Symlink Path Traversal via filter_branch Index Filter


- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114097, ECHO-7c50-8db2-9fd8, GHSA-4hjw-xcwg-8xfj, GHSA-5fqc-mrg8-w798, MINI-5c5m-hq9j-pr77, MINI-rwj7-4gcx-62h9, UBUNTU-CVE-2026-114097

## What is CVE-2026-114097?

CVE-2026-114097 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 

### Official description

Dulwich from 0.23.1 before 1.2.8 contains a path traversal vulnerability in CommitFilter._apply_index_filter() that allows attackers to write files outside the working directory via symlinks persisting between commits. Attackers can craft a repository where an ancestor commit's symlink redirects a descendant commit's file writes during filter_branch, enabling code execution by writing into .git/hooks.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-114097?

2 open source packages ship an affected version, including dulwich.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | From 0.23.1 | 1.2.8 |
| `dulwich` | PyPI | From 0.23.1 | 1.2.8 |

## How do I fix CVE-2026-114097?

Upgrade dulwich to 1.2.8 or later.

## Is CVE-2026-114097 being exploited?

There is no known exploitation of CVE-2026-114097 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114097 and fix it if it is affected.

What it is: CVE-2026-114097 is a high-severity vulnerability in jelmer dulwich, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114097 in the wild and no public exploit code.

Affected packages and fixed versions:
- dulwich (PyPI): affected from 0.23.1; fixed in 1.2.8
- dulwich (PyPI): affected from 0.23.1; fixed in 1.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114097/ (Markdown: https://insights.sbomify.com/CVE-2026-114097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114097
- OSV: https://osv.dev/vulnerability/CVE-2026-114097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114097/
Summaries are generated and may contain mistakes; the official description above is the record.
