# CVE-2026-114102: adm-zip before 0.6.1 Denial of Service via inflateAsync Unhandled Error Event


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** CLEANSTART-2026-IF17943, CLSA-2026-1791627044, ECHO-c388-a2f8-a3cc, GHSA-8238-w5pm-2374, GHSA-f9g8-qp78-x5c2, MINI-2gpx-39wc-7m56, MINI-43mm-73r8-chrf, MINI-47vx-987m-6wvr, MINI-9fvr-g78m-qxc5, MINI-cjhf-gj96-83jw, MINI-hcg7-7rq5-cj59, MINI-hw2q-wp8q-v7hr, MINI-j2pg-fx6g-mr94, MINI-m7f7-g46p-6jh2, MINI-q38v-hpjr-98jc, MINI-qhwm-8h65-25hc, MINI-v8wj-2w42-xwvr, MINI-xf8f-q665-9j8g, MINI-xhjc-gw48-gqwp, ROOT-APP-NPM-GHSA-8238-w5pm-2374

## What is CVE-2026-114102?

CVE-2026-114102 is a high-severity vulnerability in cthackers adm-zip, published on 21 Oct 2026. 

### Official description

adm-zip before 0.6.1 contains a denial of service vulnerability that allows unauthenticated attackers to crash the Node.js process via a malformed ZIP file, because inflateAsync in methods/inflater.js lacks a zlib stream error listener. Attackers can supply a ZIP with corrupted DEFLATE data processed by readFileAsync, readAsTextAsync, extractAllToAsync, or getDataAsync, triggering an uncatchable exception that terminates all in-flight requests.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-114102?

2 open source packages ship an affected version, including adm-zip.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adm-zip` | npm | All versions | 0.6.1 |
| `adm-zip` | npm | All versions | 0.6.1 |

## How do I fix CVE-2026-114102?

Upgrade adm-zip to 0.6.1 or later.

## Is CVE-2026-114102 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114102 exists.

Public exploit code:

- Node.js app using adm-zip (CVE-2026-114102 DoS) (github_poc): https://github.com/anywaye/nilepatch-admzip-dos

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114102 and fix it if it is affected.

What it is: CVE-2026-114102 is a high-severity vulnerability in cthackers adm-zip, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114102 exists.

Affected packages and fixed versions:
- adm-zip (npm): affected all versions; fixed in 0.6.1
- adm-zip (npm): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114102/ (Markdown: https://insights.sbomify.com/CVE-2026-114102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114102
- OSV: https://osv.dev/vulnerability/CVE-2026-114102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114102/
Summaries are generated and may contain mistakes; the official description above is the record.
