# CVE-2026-114104: adm-zip before 0.6.1 Duplicate ZIP Entry Name Validation Bypass


- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** CLEANSTART-2026-DD09882, CLSA-2026-1790854760, CLSA-2026-1790868332, CLSA-2026-1790869902, CLSA-2026-1791666093, CLSA-2026-1791666292, ECHO-b36c-2463-3211, GHSA-mr8q-rv22-x3fr, GHSA-p634-w6r4-rjp2, MINI-228r-8g37-8gwf, MINI-2r2m-jph9-rpfw, MINI-33gr-h5v2-x2cr, MINI-43gh-3q8j-h342, MINI-929x-fmvh-c9wq, MINI-ffxx-f84f-jvj4, MINI-fgj2-q988-jpjp, MINI-jchj-22r8-2mm5, MINI-jgph-89qq-2gq5, MINI-mhrg-v9jc-vm48, MINI-pgwc-rc65-qqwh, MINI-q6p6-rg7h-7hww, MINI-rx6x-jxqg-vfqc, MINI-xwc5-5jmm-7c2g

## What is CVE-2026-114104?

CVE-2026-114104 is a high-severity vulnerability in cthackers adm-zip, published on 21 Oct 2026. 

### Official description

adm-zip before 0.6.1 contains an inconsistent entry resolution vulnerability that allows attackers to bypass content validation by supplying ZIP archives with duplicate entry names. Attackers can craft archives where getEntry() returns the last duplicate while extractAllTo() writes the first, causing unvalidated bytes to be written to disk.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-114104?

2 open source packages ship an affected version, including adm-zip.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adm-zip` | npm | All versions | 0.6.1 |
| `adm-zip` | npm | All versions | 0.6.1 |

## How do I fix CVE-2026-114104?

Upgrade adm-zip to 0.6.1 or later.

## Is CVE-2026-114104 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114104 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114104 and fix it if it is affected.

What it is: CVE-2026-114104 is a high-severity vulnerability in cthackers adm-zip, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114104 exists.

Affected packages and fixed versions:
- adm-zip (npm): affected all versions; fixed in 0.6.1
- adm-zip (npm): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114104/ (Markdown: https://insights.sbomify.com/CVE-2026-114104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114104
- OSV: https://osv.dev/vulnerability/CVE-2026-114104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114104/
Summaries are generated and may contain mistakes; the official description above is the record.
