# CVE-2026-114106: HKUDS Vibe-Trading 0.1.0 before 0.1.7 Path Traversal via read_document and safe_user_path


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-5rmq-chc7-m22f, GHSA-c5xj-9gp4-c84p

## What is CVE-2026-114106?

CVE-2026-114106 is a high-severity vulnerability in HKUDS Vibe-Trading, published on 21 Oct 2026. 

### Official description

HKUDS Vibe-Trading from 0.1.0 before 0.1.7 contains a path traversal vulnerability that allows remote attackers to read sensitive server files through LLM agent file-read tools. Attackers can prompt the agent to invoke read_document, which lacks sandbox checks, or safe_user_path-gated tools to leak /etc/shadow, /proc/self/environ API keys, and /root credentials.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-114106?

2 open source packages ship an affected version, including vibe-trading-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vibe-trading-ai` | PyPI | From 0.1.0 | 0.1.7 |
| `vibe-trading-ai` | PyPI | From 0.1.0 | 0.1.7 |

## How do I fix CVE-2026-114106?

Upgrade vibe-trading-ai to 0.1.7 or later.

## Is CVE-2026-114106 being exploited?

There is no known exploitation of CVE-2026-114106 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114106 and fix it if it is affected.

What it is: CVE-2026-114106 is a high-severity vulnerability in HKUDS Vibe-Trading, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114106 in the wild and no public exploit code.

Affected packages and fixed versions:
- vibe-trading-ai (PyPI): affected from 0.1.0; fixed in 0.1.7
- vibe-trading-ai (PyPI): affected from 0.1.0; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114106/ (Markdown: https://insights.sbomify.com/CVE-2026-114106/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114106
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114106
- OSV: https://osv.dev/vulnerability/CVE-2026-114106

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114106/
Summaries are generated and may contain mistakes; the official description above is the record.
