# CVE-2026-114107: HKUDS Vibe-Trading 0.1.0 before 0.1.7 Indirect Prompt Injection RCE via BashTool and BackgroundRunTool


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** GHSA-66r3-5f65-g64j, GHSA-jqmf-mx4f-hfr6

## What is CVE-2026-114107?

CVE-2026-114107 is a high-severity vulnerability in HKUDS Vibe-Trading, published on 21 Oct 2026. 

### Official description

HKUDS Vibe-Trading from 0.1.0 before 0.1.7 contains an indirect prompt injection vulnerability that allows remote attackers to execute shell commands as root by planting instructions in documents or web pages the agent processes. BashTool and BackgroundRunTool pass model-emitted commands to subprocess.run with shell=True and no allow-list or approval step, and read_url fetches arbitrary URLs, enabling command execution and server-side request forgery.

Weakness: CWE-1427 (Improper Neutralization of Input Used for LLM Prompting)

## Which versions are affected by CVE-2026-114107?

2 open source packages ship an affected version, including vibe-trading-ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vibe-trading-ai` | PyPI | From 0.1.0 | 0.1.7 |
| `vibe-trading-ai` | PyPI | From 0.1.0 | 0.1.7 |

## How do I fix CVE-2026-114107?

Upgrade vibe-trading-ai to 0.1.7 or later.

## Is CVE-2026-114107 being exploited?

There is no known exploitation of CVE-2026-114107 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114107 and fix it if it is affected.

What it is: CVE-2026-114107 is a high-severity vulnerability in HKUDS Vibe-Trading, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114107 in the wild and no public exploit code.

Affected packages and fixed versions:
- vibe-trading-ai (PyPI): affected from 0.1.0; fixed in 0.1.7
- vibe-trading-ai (PyPI): affected from 0.1.0; fixed in 0.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114107/ (Markdown: https://insights.sbomify.com/CVE-2026-114107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114107
- OSV: https://osv.dev/vulnerability/CVE-2026-114107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114107/
Summaries are generated and may contain mistakes; the official description above is the record.
