# CVE-2026-114109: uv before 0.11.15 Arbitrary File Write via Entry Point Names


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114109, ECHO-67a4-7019-33be, GHSA-4gg8-gxpx-9rph, GHSA-m8vc-5xpp-qpqf, MINI-8pwv-96gq-8r76, ROOT-APP-PYPI-GHSA-4gg8-gxpx-9rph, UBUNTU-CVE-2026-114109

## What is CVE-2026-114109?

CVE-2026-114109 is a high-severity vulnerability in astral-sh uv, published on 21 Oct 2026. 

### Official description

uv before 0.11.15 contains a path traversal vulnerability that allows malicious wheels to write files outside the scripts directory via crafted console_scripts or gui_scripts entry point names. Attackers who induce users to install a malicious wheel can place executables in PATH directories, shadowing or overwriting existing binaries for code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-114109?

4 open source packages ship an affected version, including uv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uv` | PyPI | All versions | 0.11.15 |
| `uv` | PyPI | All versions | 0.11.15 |
| `uv` | crates.io | All versions | 0.11.15 |
| `uv` | crates.io | All versions | 0.11.15 |

## How do I fix CVE-2026-114109?

Upgrade uv to 0.11.15 or later.

## Is CVE-2026-114109 being exploited?

There is no known exploitation of CVE-2026-114109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114109 and fix it if it is affected.

What it is: CVE-2026-114109 is a high-severity vulnerability in astral-sh uv, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114109 in the wild and no public exploit code.

Affected packages and fixed versions:
- uv (PyPI): affected all versions; fixed in 0.11.15
- uv (PyPI): affected all versions; fixed in 0.11.15
- uv (crates.io): affected all versions; fixed in 0.11.15
- uv (crates.io): affected all versions; fixed in 0.11.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114109/ (Markdown: https://insights.sbomify.com/CVE-2026-114109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114109
- OSV: https://osv.dev/vulnerability/CVE-2026-114109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114109/
Summaries are generated and may contain mistakes; the official description above is the record.
