# CVE-2026-114110: Astral uv before 0.11.6 Arbitrary File Deletion via Wheel RECORD Entries


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114110, ECHO-a619-0831-e660, GHSA-pjjw-68hj-v9mw, UBUNTU-CVE-2026-114110

## What is CVE-2026-114110?

CVE-2026-114110 is a high-severity vulnerability in astral-sh uv, published on 21 Oct 2026. 

### Official description

Astral uv before 0.11.6 contains a path traversal vulnerability that allows attackers to delete arbitrary files by supplying wheels with relative traversal paths in RECORD entries. Attackers can craft a malicious wheel whose RECORD references files outside the installation prefix, causing uv to delete those files when the user uninstalls the package.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-114110?

2 open source packages ship an affected version, including uv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uv` | PyPI | All versions | 0.11.6 |
| `uv` | PyPI | All versions | 0.11.6 |

## How do I fix CVE-2026-114110?

Upgrade uv to 0.11.6 or later.

## Is CVE-2026-114110 being exploited?

There is no known exploitation of CVE-2026-114110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114110 and fix it if it is affected.

What it is: CVE-2026-114110 is a high-severity vulnerability in astral-sh uv, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114110 in the wild and no public exploit code.

Affected packages and fixed versions:
- uv (PyPI): affected all versions; fixed in 0.11.6
- uv (PyPI): affected all versions; fixed in 0.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114110/ (Markdown: https://insights.sbomify.com/CVE-2026-114110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114110
- OSV: https://osv.dev/vulnerability/CVE-2026-114110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114110/
Summaries are generated and may contain mistakes; the official description above is the record.
